Braccio shield Error


I’ve completely assembled my Braccio arm, connected up all the motors and installed the Braccio libraries, but I cannot run testBraccio90 as the red motor error light is lit up on the shield and I’m not sure what’s causing the error.
I have connected the power supply that comes with the kit to a multiplug socket
Any help is appreciated! Thank you.

Thank you so much in advance for your help!


What are you using as the power adapter?
Can you please send pictures of your setup?

  • A red LED (LED ERR) signals that the shield is not correctly powered

Hi , I’m using the power supply that came with the braccio kit and have plugged it into a Multiplug socket. Picture attached. The last one on the left is the the thing that came with the braccio kit…

Have you tried using it without the multisocket?

No, do u think that is the problem?, It’s a power supply of 5V, 5A and i assumed it would draw the regulated power irrespective of where it’s plugged , sorry I’m not good electronics :slight_smile:

it COULD be the issue, but just to make sure, verify without the multisocket and let me know how it goes.

Connecting it to direct supply also didnt work , I tried another braccio shield and got the same red ERROR LED lit.


Then it is safe to assume the issue is due to the power supply, as the RED error LED is supposed to be due to a power issue.

What should I be using then fr power supply?

Possibly the same as this one, it’s possible the one you have is damaged / defective

I plugged in another braccio shield but it also gives the same red LED error.

Have you purchased this arm with RobotShop?
If not, I suggest you to contact your reseller and/or Arduino directly for this issue.