BNO055 empty readvalues


I have a problem with my BNO055 9 DOF Absolute Orientation IMU module.

I tried using the Adafruit libraries, of which there are many working examples on the internet, to read out the sensor on both Raspberry Pi and Arduino Uno. On both, I get no readings from the sensor. The device is detected on the I2C bus but the software only returns zero values.

I don’t have an oscilloscope at my disposal, but I do have a multimeter. With this, by the way, I don’t measure weird things. If I connect an INA219 to the same bus, I can read it.

How can I solve this problem? Or how can I find out if my sensor is faulty?

Thanks in advance

1 Like

Hello @Appleflapskeeh !

Thank you for choosing RobotShop.

According to the product page (BNO055 9 DOF Absolute Orientation IMU Module - RobotShop) it says that default mode is serial communication, but this is easily changed to I2C by closing a link on the board.

Have you done this?

Thanks @igor_X

I have indeed changed the default mode to i2c by soldering the connection on the sensor.
Processing: afbeelding.png…

Additional information:
-For the Raspberry Pi, I went through these steps:

-For Arduino I use the following driver:

1 Like

Hi @Appleflapskeeh!

In this case, I would recommend that you write [email protected] since they are supplier of this sensor.

Maybe there is something about it that we don’t know, or if it is defective they will help about the replacement.

1 Like

Thanks to robot electronics support, I have the solution.

The Adafruit libraries use an external crystal. The library works on this particular sensor by removing the following line:

1 Like

Great to hear that you have solved it :slight_smile:

Thank you for sharing.