Arduino Uno with Makerfabs ESP8266 Wifi Shield


I purchased an Arduino Uno (came with RB-Adu-48) along with the ESP8266 Wifi Shield (RB-Mkf-14) from RobotShop.

I’m not having luck connecting to wifi or seeing the shield.

I followed the instructions, but step 3 was not clear to me:
3. Make sure the jumper on the shield matches the RX/TX Arduino pin (TX-TX and RX-RX)
My jumpers were on 0 and 1, but i’m not sure where to move them initially for this step. I tried leaving them and also removing them. I could never upload sketches when the shield was on, but i removed the shield and uploaded the sketch. I’m not entirely sure what this step is about, but imagine if i get it right then i can upload with the shield connected.

Eventually, I set the pins as described in step 11 and 12. The library is installed and no issues compiling.

I don’t see anything with the options selected Both NL & CR and set the BAUD rate to 115200. But, I did follow the instructions attempting to change the wifi shield to 9600. With the serial set back to newline to 9600, I see the following:

[WiFiEsp] Initializing ESP module
[WiFiEsp] >>> TIMEOUT >>>
[WiFiEsp] >>> TIMEOUT >>>
[WiFiEsp] >>> TIMEOUT >>>
[WiFiEsp] >>> TIMEOUT >>>
[WiFiEsp] >>> TIMEOUT >>>
[WiFiEsp] Cannot initialize ESP module
[WiFiEsp] >>> TIMEOUT >>>
[WiFiEsp] No tag found
WiFi shield not present.

It doesn’t seem to see the shield.

Thanks for your help.

Sorry, I solved this…
Basically, I found that the Arduino board RX TX is actually on the board at pin 0 and 1. I saw it elsewhere but not here until now. I tried again with the pins at 0 and 1. Originally the were 1 and 0. I got an answer back when typing in the serial monitor. I repeated and now I see it’s connected!!!

I’m really having a great time with this stuff. I got the sensor data from my kit (great value) displaying to a local web server. I received some additional info from Makerfab. This happened because the Arduino Uno uses 9600, but by default the Makerfab board communicates at 115200.

  1. Cannot upload sketches when the shield is connected to the Arduino Uno

    The default baud Baud rate of the ESP-12F is 115200, so we set the hardware serial port (D0-D1) communication with the ESP-12F. so you will cannot upload the sketches to the uno when plug the wifi shield.


1.Work with Ardino UNO: Set the Baud rate of ESP-12F to 9600, then use the software serial port to communication with the WIFI, Such as the (D0-D1).

  1. work with Arduino leonado: use the Serial1(D0-D1) working with ESP-12F 115200
1 Like

I’m glad to see you’ve found a solution to solve the issue.
I think the topic will still be available in case someone else would encounter this problem.

1 Like

Hi CB!

May I know what component are you talking about of the software serial port (D8-D9)?

I believe that was a typo, it should have read D0-D1. I edited the solution in the previous post. Basically you can see where RX/TX is located on the Arduino board. This should be located next to the pin number. On my board, the RX was on 0 and the TX on 1. In addition, if you have a Leonardo you don’t need to set the communication as both boards use 115200 by default. But, you may need to adjust change the jumper on the Wifi board depending on your Aruduino. If you have an Uno like me you will need to change the communication speed to 9600 on the Wifi board. I also had to move a jumper pin on the Wifi board to match the RX/TX location on my Arduino.

I’m using Arduino Robot in my project and the hardware serial port has been used so I can only use software serial port for the WiFi connection and thus I need to change the baud rate to 9600 although the Arduino Robot acts like Arduino Leonardo. Therefore, I’m curious how you connect the ESP-12F with the Arduino Uno. Can you show the connection? Many thanks in advance!

thank you for your replies…i was also having similar question.
best regards!!

1 Like

I have the same problem and output in the serial monitor with my ESP8266 WIFI Shield (RB-Mkf-14)
WiFi Shield not present, etc.
I had the shield working fine then I change the jumper positions and now I have the same problem.
I have put the Jumpers back to RX3, and TX 2 as per when it was working but something has has happened.

Does anyone have any suggestions as to how I can get it working again ? What I might have done wrong ? Thanks for any input.

Sorry for resuscitating and old thread, but I’m unable to get the Wifi Shield to initialize.

I’m using an Arduino Mega as the host.

I’ve managed to configured the shield to a baud rate of the 9600. The thing does not work when I try to initialize the shield with the Arduino sample project. I’ve tried multiple jumper configuration without success.

Right now the configuration on the shield is ESP_TX->D7 and ESP_RX->D6.

I’ve tried SoftwareSerial SerialSoft(6, 7) and SoftwareSerial SerialSoft(7, 6). Both give me the same result : WiFi shield not present

thanks for your help

Finally, I’ve figured out what was not working. The RX/TX on the shield only goes up to D7. Unfortunately, the SoftwareSerial for the Arduino Mega is only compatible starting from pin D10 (Source).

So to workaround this limitation, you have to remove the jumpers and connect the ESP_(RX|TX) directly to TX1|RX1. In the code use Serial1.