Arduino Uno R3 Refusing Upload

After a very long absence, I have finally returned. I'll bet none of you even remember me!

Anyway, I got  a new Arduino Uno R3 yesterday in the mail. I installed Arduino Software 1.6.3 (latest stable release) and tried to upload the Example sketch, Blink.

It compiles fine and finds the board fine. But when it comes to uploading, it always get's stuck. It never gives me a message telling me the upload is completed. The progress bar always stops at about 80%. I have been letting it sit like that for about an hour now.

Any ideas?

What OS are you using and is it a Clone board or real one?

What OS are you using and is it a Clone board or real one?

Windows 8.1. How to I find

Windows 8.1. How to I find out if it’s a clone or the real one?

Did you install the

Did you install the necessary drivers? Have you chosen the correct serial port?

Do not use the latest Arduino IDE. Use 1.0 to test your board.

The drivers where installed

The drivers where installed by the board when I first plugged it in. I even tried to uninstall and reinstall. It can see the serial port the board is on. My Device Manager confirms that the port it says my board is on is correct. I’ll try 1.0 see if that works.

This is what v1.0 gives

This is what v1.0 gives me:

avrdude: ser_send(): write error: sorry no info avail

According to this page, I

According to this page, I have a original board.

You have the wrong serial

You have the wrong serial port selected. Make sure the driver is installed and you have the correct serial port number. Check out the tutorial here.

You need to choose the

You need to choose the correct serial port at your IDE GUI as well…Remember what your device manager says and choose the port accordingly at your IDE!

Following that tutorial

Following that tutorial won’t let me manually install an older driver. Windows 8.1 doesn’t let me do it that way. I’ll look around and see if I can figure that out.

As for the port being

As for the port being wrong,


The number on the COM ports match. I am thinking that there has to be a problem with the board itself.

Ok. Close the IDE and any

Ok. Close the IDE and any Arduino program. Unplug USB cable. Plug it in again. Open IDE, re-check board and serial port, try to download blink program again.

Make also sure the chip is inserted correctly.

Do you have anything else connected to the board beside the USB cable?

I figured out the problem!It

I figured out the problem!

It turns out that there is a conflict between the Belkin WiFi dongle and the Arduino drivers.

So if you have this problem and you also have a Belkin device attached to your PC, I would recommend that you remove the Belkin and upload to your hearts content.