APC220 problem @ connecting Arduino Uno



received the radio module today. Expected to have it up and running quickly but in stead it drove me crazy. Goal is to establish wireless serial communication between my laptop and the Uno. I have a Windows 7 laptop, an Arduino Uno and a IO expansion shield for plugging in the APC (http://www.dfrobot.com/wiki/index.php/IO_Expansion_Shield_For_Arduino(V5)_(SKU:_DFR0088))


I followed the dfrobot wiki (http://www.dfrobot.com/index.php?route=product/product&product_id=57#.UQRdGR0sBx9)

Downloaded the VPC Driver Kit from Silicon labs http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx

Installed the Drivers and “linked” the APC to a (lower numbered) com port (used both [a] the same comport that I always Used for Arduino communication and [b] other com port numbers). See picture.


Next step: downloaded and installing the RF-Magic configuration software.

So far everything ok, but then … grr!

I was not able to see the APC in the RF-Magic. I tried several com ports, but no success (see picture).

Question: what am I doing wrong?


I experimented a bit.

I uploaded a sketch via the USB-cable connection.

Detached the USB-cable and plugged the APC’s in (one @ laptop, the other @IO expansion shield)

And …… had wireless serial communication: saw the Uno spitting text and number at my serial monitor.

Was not able though to upload a modificated sketch via the APC-connection and got “avrdude: stk500_getsync(): not in sync: resp=0x00” in my IDE.

Same error-message if USB cable reconnected, no APC @ laptop, other APC still @ IO-shield.

Assume that it must be possible to upload via APC-connection and via USB-connection (with APS still @ IO shield).

Again: what am I doing wrong?

Hope you can help me.

Thanks in advance.

Regards, Ko



**I am no expert. Heck, I am not even a beginner when it comes to **

arduino uploading, but, I believe you require a reset pin to be connected to be able to upload sketches.

Just got mine working

I just got my APC220 connection working (Arduino Mini, not yet tried the Arduino UNO).

Scratched my head for a while getting the settings software to work as it wouldn’t show any serial ports (I had followed the instructions to reduce the COM port number to something reasonable) but it wasn’t until I ran the settings software as an Administrator that it would show any COM ports. Infuriating when it’s something as simple but obscure as that.

Not tried uploading sketches to the Arduino Mini using the APC220, it’d be nice but not really necessary as I can use the included USB-TTL adapter that comes with the APC220’s. I did try reading up on it but I gave up when I saw the Mini uses 115200 for uploads and the APC220’s are currently set at 57600 (though the through-the-air baud rate is 9600 the microcontroller on each APC220 does some buffering, if I have understood all that I recently read correctly).

Hope this helps with your problem.


Ran RF Magic as admin - but still no com ports


followed Mark’s suggestion and ran the RF Magic settings software as administrator. On the desktop a small config file (netsetup) appeared (seemed good news to me :wink: with following contents:


But … still no com ports @ RF Magic.

Looking forward to your tips and  suggestions :wink:

Regards, Ko

What com port number for the APC?

Must the he APC com port number be equal to my “normal Arduino port number” or is it important to give it an other number?

Regards, Ko

Must APC TX/RX-connection be broken for ketch upload?


Solved, but still some questions left!


Found following helpful links:

·         http://www.asvresearch.com/main/index.php/tutorials/tutorial-1?showall=1&limitstart=

·         http://www.rcgroups.com/forums/showthread.php?t=1382503&page=96

·         http://arduino-elechouse.blogspot.nl/2010_04_01_archive.html

·         http://arduino.cc/forum/index.php?action=printpage;topic=83653.0 

What I did:

·         Followed dfrobot wiki (http://www.dfrobot.com/index.php?route=product/product&product_id=57#.UQRdGR0sBx9)

·         Download the VPC Driver Kit from Silicon labs http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx

·         Installed the Drivers

·         Connected the USB converter (with APC plugged on) to my laptop => Windows installed device driver software automatically. Checked device manager to ensure everything went ok (no yellow triangles and exclamation marks at line “Silicon labs … USB to UART Bridge”) 

·         Plugged other APC in Arduino (in my case @ IO expansion shield).

·         Configured the USB adapter to a (lower numbered) com port and set the baudrate to 9600. Picked another com port number as my “regular Arduino port number” to create two separate serial channels (one via Usb cable and one wireless). Steps: Windows device manager: right click the device > properties > port settings > advanced > com port  number / bits per second.

·         Download the RF-Magic configuration software (http://www.dfrobot.com/image/data/TEL0005/rfmagic.rar).

·         Ran the downloaded (RF Magic) executable APC22X_V12A for configuring the APC’s. It is mandatory to do that as administrator, otherwise there is no com port visible @ “RF Magic configurator”. Set com port to the number earlier configured for USB adapter. Save settings with the “write button” and pay attention to the status bar


Now everything is setup. The usage however is not strait forward. Findings:

·         For sketch uploading: (1) unplug the APC from the Arduino (otherwise no uploading!) (2) attach USB- cable, (3) select corresponding (regular) com port @ IDE and finally (4) upload sketch. From the found information I learned that the connection of TX and RX on APC220 must be broken, otherwise downloading will go wrong. In my case that is physically unplugging the APC from the IO expansion shield (ugh ;-).

·         If the sketch is uploaded: (1) remove USB cable, (2) plugin APC @ Arduino, (3) select com port for wireless communication in IDE and (4) open serial monitor and …. wireless serial monitor established :wink:



1.       Is it really necessary to break TX / RX connection on APC for sketch uploading ? That is devious if you use an IO expansion shield as I do. I consider to attach the APC differently: so that I can break the connection with a switch instead of physically removal of the APC.

2.       Is it really necessary to set up two separate serial channels or is there a charming alternative?

Curious at your replies. 

Regards, Ko



Uploading sketches

Ko, it is my experience that breaking the APC Tx to Arduino Rx is necessary when uploading sketches (I leave the APC Rx to Arduino Tx in place without any trouble but I only do that because (a) I have each pin connected by jumpers seperately and (b) I’m lazy and don’t want to disconnect both power, Tx and Rx connections to the APC.

I’m not sure why you would want to share the same com port. I have different com ports (serial channels) for each device and this allows me to plug in multiple devices without interference. One possible downside is having to select different ports (say in Arduino environment) but this is a useful reminder to me that I haven’t changed the board type (Mega uses COM 10, UNO uses COM 5, Duemilanove uses COM … etc etc).


[SOLVED] APC220 setup and "TX/RX-wiring"

Mark, thanks for sharing your experience. I found more supporting info regarding the need for breaking the TX/RX-connection (it is as it is ;-). I copied your jumper solution (with a dipswitch) and everything functions well. Ko

how do you run it as

how do you run it as adminstrator?

Hi everyone,
I have had problems with my apc220, everything was ok, one day I left to received data in my serial monitor, the driver for the usb-ttl apears like CH-340, never likes silab …, I have uninstalled this driver bit my Windows 10 does not hey this driver.
Some similar do you happen ?, I need help. Thanks ,!!