Actuonix (Firgelli) LAC Control via USB with Raspberry Pi

Howdy y’all,

I am trying to control an Actuonix P16 200mm Linear Actuator with an LAC and Raspberry Pi B+. I was wondering if anyone knows if there is a way to control the LAC via USB connection with the Raspberry Pi.

I ideally want to use USB instead of a PWM signal because I want to be able to update the PD control so my actuator isn’t stuttering when approaching a value. But if I could change those values without needing a USB connection, it would be greatly appreciated if you tell me how to do that instead.

In terms of software and steps I have already taken, I am currently using Debian Bullseye, and was able to confirm that the Raspberry Pi was able to see the board when I ran $ dmesg, but not call to it nor connect to the LAC. The vendor ID and product ID are the standard 0x04D8 and 0xFC5F.

Important Note: Before anyone starts asking about why am I using a Raspberry Pi, it is because I am using the board to get important debugging and telemetry data for my project, and I need to use its USB ports to send data to a csv file on a USB drive.

Thank you in advance for any help.

Hello @troybaxter99!

Maybe this could work for you?


I’ve tried following the steps outlined in that repository yesterday, and I still couldn’t get it to work. I’ve downloaded libusb-1.0, updated edit-sources to include the debian line the author listed (I made sure to use bullseye instead of stretch), added the 50-firgelli-ubuntu rule to /etc/udev/rules, and moved the lac.C and setall to programs to /bin/. After completing those steps and rebooting my Pi, the green light still didn’t turn on. I have no clue what I am missing from that repository. Could it be that I am suppose to use the gentoo or suse rules instead?

Could it be that I am suppose to use the gentoo or suse rules instead?

Not sure but I guess it won’t hurt to try that

You could also create an issue on that repository or try contacting the email [email protected]

So… I have zero clue what I did, but I somehow got it to work via USB connection. Whenever I do figure it out, I will try to explain on this thread how I figured it out so others can understand if they are stuck in this situation like I was.


Hi @troybaxter99 ,

Did you manage to find a root cause? :slight_smile: