Lynxmotion Rover PS2 Controller Arduino Code

Can someone please give me the correct Arduino code to use for the Lynxmotion rover using a PS2 controller? I’ve looked and looked and tried and tried what I found and nothing works! Please, what code do I use?

1 Like

Hey @pwpolick!

The best place to look would be in the Lynxmotion GitHub. The repository is Rovers.

There are five major examples in that repository:

Let me know if you have some questions.


P.-S.: You probably should post more details about what hardware you are using (other than the “Arduino” and "PS2 and “rover”), such as direct links to the products/specs and also pics of your project, making sure to clearly show key components such as electronics, connections, settings (jumpers, switches, etc.). Feel free to annotate your images if it can help clarify details.

1 Like

Lynxmotion PS2 Arduino Error Messages.pdf (70.8 KB)

I’ve uploaded a picture of the Lynxmotion rover we are using, and the error messages I’m getting when I upload the Arduino code. Look . . . I’m a teacher, have students working on this . . . I need the straight and to the point Arduino code that will work, I don’t have time hunting all over the place trying this and trying that. Sorry for venting, but just seems like this is a wild goose chase . . . there’s no one to call for help, just this forum, and like I said before . . . I’ve tried and tried and tried all that’s posted here, github, Bill Porter, etc and nothing’s working . . . Please help, thank you!

1 Like

Those error messages means there is no connection between the Arduino IDE (through avr-dude, the programming software) and your Arduino-compatible board.

This is the most generic error and simply indicates it cannot find the board and thus times out…

Is there anything connected on the arduino board that uses pins 0 or 1 ? If so, please disconnect those and try again.

Can you confirm that jumper 17 (as in the image below) is set to USB as opposed to Ext? This jumper selects where the power to the microcontroller comes from. If you chose Ext and there is no 9V battery connected, then the microcontroller is not receiving any power and therefore you would not be able to establish connection.

Also, before powering, ensure you have the DIP switches on the Sabertooth correct:

last, and only a minor aesthetic note, but it seems like your top plastic plate might still have the protective (clear) backing.


1 Like

We can’t get the Arduino board to work with the program, so figured to abandon ship. Any way we can connect a Spectrum or Fly Sky radio controller to this Lynxmotion Rover? Suggestions to make this work (what to use, battery, etc)?

We can’t get the Arduino board to work with the program.

Can you give us an idea of what point you got to?

Any way we can connect a Spectrum or Fly Sky radio controller to this Lynxmotion Rover?

It looks like you have the version of the Sabertooth which offers direct RC connection. However, unlike the guide suggests, it seems you cut the red (5V) wire rather than the approach suggested in the manual which allows you to reuse it if needed:

If you can sort out reconnecting this wire, regarding parts and connections, you only need the remote and receiver, and the Sabertooth plugs right in. You can follow the guide here:
Almost any 4ch RC remote would work. it’s up to you as to which battery to choose: either a 12V NiMh or a 3S (11.1V) LiPo. Ex:

1 Like